uget-1.10.3.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. IUSE="aria2 +curl gstreamer hide-temp-files libnotify nls"
  5. if [[ ${PV} == *9999* ]]; then
  6. inherit autotools git-2
  7. KEYWORDS=""
  8. SRC_URI=""
  9. EGIT_REPO_URI="git://git.code.sf.net/p/urlget/uget"
  10. else
  11. KEYWORDS="amd64 ppc x86"
  12. SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
  13. fi
  14. DESCRIPTION="Download manager using gtk+ and libcurl"
  15. HOMEPAGE="http://www.ugetdm.com"
  16. LICENSE="LGPL-2.1"
  17. SLOT="0"
  18. REQUIRED_USE="|| ( aria2 curl )"
  19. RDEPEND="
  20. dev-libs/libpcre
  21. >=dev-libs/glib-2.32:2
  22. >=x11-libs/gtk+-3.4:3
  23. curl? ( >=net-misc/curl-7.10 )
  24. gstreamer? ( media-libs/gstreamer:0.10 )
  25. libnotify? ( x11-libs/libnotify )
  26. "
  27. DEPEND="${RDEPEND}
  28. dev-util/intltool
  29. virtual/pkgconfig
  30. sys-devel/gettext"
  31. src_prepare() {
  32. if [[ ${PV} == *9999* ]]; then
  33. eautoreconf
  34. intltoolize || die "intltoolize failed"
  35. eautoreconf
  36. fi
  37. }
  38. src_configure() {
  39. econf $(use_enable nls) \
  40. $(use_enable curl plugin-curl) \
  41. $(use_enable aria2 plugin-aria2) \
  42. $(use_enable gstreamer) \
  43. $(use_enable hide-temp-files hidden) \
  44. $(use_enable libnotify notify)
  45. }
  46. src_compile() {
  47. emake || die "emake failed"
  48. }
  49. src_install() {
  50. emake DESTDIR="${D}" install
  51. # the build system forgets this :p
  52. dobin uget-cmd/uget-cmd
  53. if [[ ${PV} == *9999* ]]; then
  54. dodoc AUTHORS ChangeLog README
  55. else
  56. dodoc AUTHORS ChangeLog NEWS README
  57. fi
  58. }
  59. pkg_postinst() {
  60. if use aria2; then
  61. echo
  62. elog "You've enabled the aria2 USE flag, so the aria2 plug-in has been"
  63. elog "built. This allows you to control a local or remote instance of aria2"
  64. elog "through xmlrpc. To use aria2 locally you have to emerge"
  65. elog "net-misc/aria2 with the xmlrpc USE enabled manually."
  66. echo
  67. fi
  68. }