uget-1.8.0.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit base
  5. DESCRIPTION="Download manager using gtk+ and libcurl"
  6. HOMEPAGE="http://www.ugetdm.com"
  7. SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE="aria2 +curl gstreamer gtk3 hide-temp-files libnotify nls"
  12. REQUIRED_USE="|| ( aria2 curl )"
  13. RDEPEND="
  14. dev-libs/libpcre
  15. >=dev-libs/glib-2:2
  16. !gtk3? (
  17. >=x11-libs/gtk+-2.18:2
  18. )
  19. gtk3? (
  20. x11-libs/gtk+:3
  21. )
  22. curl? ( >=net-misc/curl-7.10 )
  23. gstreamer? ( media-libs/gstreamer:0.10 )
  24. libnotify? ( x11-libs/libnotify )
  25. "
  26. DEPEND="${RDEPEND}
  27. dev-util/intltool
  28. virtual/pkgconfig
  29. sys-devel/gettext"
  30. src_prepare() {
  31. # add missing file, fix tests, bug #376203
  32. echo "uglib/UgPlugin-aria2.c" >> po/POTFILES.in ||
  33. die "echo in po/POTFILES.in failed"
  34. }
  35. src_configure() {
  36. econf $(use_enable nls) \
  37. $(use_with gtk3) \
  38. $(use_enable curl plugin-curl) \
  39. $(use_enable aria2 plugin-aria2) \
  40. $(use_enable gstreamer) \
  41. $(use_enable hide-temp-files hidden) \
  42. $(use_enable libnotify notify)
  43. }
  44. src_compile() {
  45. emake || die "emake failed"
  46. }
  47. src_install() {
  48. emake DESTDIR="${D}" install
  49. # the build system forgets this :p
  50. dobin uget-cmd/uget-cmd
  51. dodoc AUTHORS ChangeLog NEWS README
  52. }
  53. pkg_postinst() {
  54. if use aria2; then
  55. echo
  56. elog "You've enabled the aria2 USE flag, so the aria2 plug-in has been"
  57. elog "built. This allows you to control a local or remote instance of aria2"
  58. elog "through xmlrpc. To use aria2 locally you have to emerge"
  59. elog "net-misc/aria2 with the xmlrpc USE enabled manually."
  60. echo
  61. fi
  62. }