arc-icon-theme-20161122.ebuild 870 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools gnome2-utils
  5. DESCRIPTION="Vertex icon theme"
  6. HOMEPAGE="https://github.com/horst3180/arc-icon-theme"
  7. SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. IUSE=""
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
  12. # Require adwaita until moka is packaged
  13. RDEPEND="
  14. x11-themes/adwaita-icon-theme
  15. "
  16. DEPEND=""
  17. # This ebuild does not install any binaries
  18. RESTRICT="binchecks strip"
  19. src_prepare() {
  20. default
  21. eautoreconf
  22. }
  23. pkg_preinst() {
  24. gnome2_icon_savelist
  25. }
  26. pkg_postinst() {
  27. gnome2_icon_cache_update
  28. }
  29. pkg_postrm() {
  30. gnome2_icon_cache_update
  31. }