tango-icon-theme-extras-0.1.0-r2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils gnome2-utils
  5. DESCRIPTION="Tango icons for iPod Digital Audio Player devices and the Dell Pocket DJ DAP"
  6. HOMEPAGE="http://tango.freedesktop.org"
  7. SRC_URI="http://tango.freedesktop.org/releases/${P}.tar.gz"
  8. LICENSE="CC-BY-SA-2.5"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="png"
  12. RDEPEND=">=x11-themes/tango-icon-theme-0.8.90"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig
  15. >=gnome-base/librsvg-2.34
  16. virtual/imagemagick-tools[png?]
  17. >=x11-misc/icon-naming-utils-0.8.90"
  18. RESTRICT="binchecks strip"
  19. DOCS="AUTHORS ChangeLog NEWS README"
  20. src_prepare() {
  21. epatch "${FILESDIR}"/${P}-graphicsmagick.patch
  22. epatch "${FILESDIR}"/${P}-MKDIR_P.patch
  23. sed -i -e '/svgconvert_prog/s:rsvg:&-convert:' configure{,.ac} || die #413183
  24. eautoreconf
  25. }
  26. src_configure() {
  27. econf \
  28. $(use_enable png png-creation) \
  29. $(use_enable png icon-framing)
  30. }
  31. pkg_preinst() { gnome2_icon_savelist; }
  32. pkg_postinst() { gnome2_icon_cache_update; }
  33. pkg_postrm() { gnome2_icon_cache_update; }