xoat-9999.ebuild 875 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic git-r3 savedconfig toolchain-funcs
  5. DESCRIPTION="X Obstinate Asymmetric Tiler"
  6. HOMEPAGE="https://github.com/seanpringle/xoat"
  7. EGIT_REPO_URI="https://github.com/seanpringle/xoat"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS=""
  11. DEPEND="
  12. x11-libs/libX11
  13. x11-libs/libXft
  14. x11-libs/libXinerama
  15. "
  16. RDEPEND="
  17. ${DEPEND}
  18. !savedconfig? ( x11-misc/dmenu )
  19. "
  20. src_prepare() {
  21. default
  22. restore_config config.h
  23. }
  24. src_configure() {
  25. tc-export CC PKG_CONFIG
  26. }
  27. src_compile() {
  28. XOAT_COMPILE=(
  29. ${CC} -o ${PN} ${PN}.c ${CFLAGS} -std=c99 ${LDFLAGS}
  30. $(${PKG_CONFIG} --cflags --libs x11 xinerama xft)
  31. )
  32. echo ${XOAT_COMPILE[@]}
  33. ${XOAT_COMPILE[@]} || die
  34. }
  35. src_install() {
  36. dobin xoat
  37. dodoc status xinitrc xoat.md xoatrc
  38. doman xoat.1
  39. save_config config.h
  40. }