1234567891011121314151617181920212223242526272829303132333435363738394041424344454647 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- EGO_PN="github.com/coreos/fleet"
- inherit systemd vcs-snapshot
- DESCRIPTION="A Distributed init System"
- HOMEPAGE="https://github.com/coreos/fleet"
- SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- LICENSE="Apache-2.0"
- SLOT="0"
- KEYWORDS="~amd64"
- IUSE="doc examples test"
- DEPEND="
- >=dev-lang/go-1.4:=
- test? ( dev-go/go-tools )
- "
- RDEPEND=""
- src_compile() {
- ./build || die 'Build failed'
- }
- src_test() {
- ./test || die 'Tests failed'
- }
- src_install() {
- dobin "${S}"/bin/fleetd
- dobin "${S}"/bin/fleetctl
- systemd_dounit "${FILESDIR}"/fleet.service
- systemd_dounit "${FILESDIR}"/fleet.socket
- dodoc README.md
- use doc && dodoc -r Documentation
- use examples && dodoc -r examples
- insinto /etc/${PN}
- newins "${PN}".conf.sample "${PN}".conf
- }
|