fleet-0.11.8.ebuild 892 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGO_PN="github.com/coreos/fleet"
  5. inherit systemd vcs-snapshot
  6. DESCRIPTION="A Distributed init System"
  7. HOMEPAGE="https://github.com/coreos/fleet"
  8. SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. IUSE="doc examples test"
  13. DEPEND="
  14. >=dev-lang/go-1.4:=
  15. test? ( dev-go/go-tools )
  16. "
  17. RDEPEND=""
  18. src_compile() {
  19. ./build || die 'Build failed'
  20. }
  21. src_test() {
  22. ./test || die 'Tests failed'
  23. }
  24. src_install() {
  25. dobin "${S}"/bin/fleetd
  26. dobin "${S}"/bin/fleetctl
  27. systemd_dounit "${FILESDIR}"/fleet.service
  28. systemd_dounit "${FILESDIR}"/fleet.socket
  29. dodoc README.md
  30. use doc && dodoc -r Documentation
  31. use examples && dodoc -r examples
  32. insinto /etc/${PN}
  33. newins "${PN}".conf.sample "${PN}".conf
  34. }