fleet-9999.ebuild 826 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit git-r3 systemd
  5. EGIT_REPO_URI="git://github.com/coreos/fleet.git"
  6. DESCRIPTION="A Distributed init System"
  7. HOMEPAGE="https://github.com/coreos/fleet"
  8. SRC_URI=""
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS=""
  12. IUSE="doc examples test"
  13. DEPEND=">=dev-lang/go-1.3:=
  14. test? ( dev-go/go-tools )"
  15. RDEPEND=""
  16. src_compile() {
  17. ./build || die 'Build failed'
  18. }
  19. src_test() {
  20. ./test || die 'Tests failed'
  21. }
  22. src_install() {
  23. dobin "${S}"/bin/fleetd
  24. dobin "${S}"/bin/fleetctl
  25. systemd_dounit "${FILESDIR}"/fleet.service
  26. systemd_dounit "${FILESDIR}"/fleet.socket
  27. dodoc README.md
  28. use doc && dodoc -r Documentation
  29. use examples && dodoc -r examples
  30. insinto /etc/${PN}
  31. newins "${PN}".conf.sample "${PN}".conf
  32. }