integrit-4.0.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit autotools toolchain-funcs
  4. DESCRIPTION="file integrity verification program"
  5. HOMEPAGE="http://integrit.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ppc x86"
  10. IUSE=""
  11. src_unpack() {
  12. unpack ${A}
  13. cd "${S}"
  14. sed -i -e "/^CC/d" configure.in hashtbl/configure.in || die
  15. sed -i -e "/^AC_PROGRAM_PATH/d" configure.in hashtbl/configure.in || die
  16. eautoreconf
  17. }
  18. src_compile() {
  19. tc-export AR
  20. econf
  21. emake || die
  22. emake utils || die
  23. cd "${S}"/doc
  24. emake || die
  25. cd "${S}"/hashtbl
  26. emake hashtest || die
  27. mv README README.hashtbl
  28. }
  29. src_install() {
  30. dosbin integrit || die
  31. dolib libintegrit.a
  32. dodoc Changes HACKING README todo.txt
  33. cd "${S}"/utils
  34. dosbin i-viewdb
  35. dobin i-ls
  36. cd "${S}"/hashtbl
  37. dolib libhashtbl.a
  38. insinto /usr/include
  39. doins hashtbl.h
  40. dobin hashtest
  41. dodoc README.hashtbl
  42. cd "${S}"/doc
  43. doman i-ls.1 i-viewdb.1 integrit.1
  44. doinfo integrit.info
  45. cd "${S}"/examples
  46. docinto examples
  47. dodoc *
  48. }
  49. pkg_postinst() {
  50. elog "It is recommended that the integrit binary is copied to a secure"
  51. elog "location and re-copied at runtime or run from a secure medium."
  52. elog "You should also create a configuration file (see examples)."
  53. }