ngxtop-0.0.2-r1.ebuild 651 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. PYTHON_REQ_USE="sqlite"
  6. inherit distutils-r1
  7. DESCRIPTION="real-time metrics for nginx server (and others)"
  8. HOMEPAGE="https://github.com/lebinh/ngxtop"
  9. SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. SLOT="0"
  11. LICENSE="MIT"
  12. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  13. IUSE=""
  14. RDEPEND="
  15. dev-python/docopt[${PYTHON_USEDEP}]
  16. dev-python/pyparsing[${PYTHON_USEDEP}]
  17. dev-python/tabulate[${PYTHON_USEDEP}]"
  18. DEPEND="${RDEPEND}
  19. "
  20. PATCHES=( "${FILESDIR}"/${P}-py3.patch )