ngxtop-0.0.3_pre141201.ebuild 724 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  5. PYTHON_REQ_USE="sqlite"
  6. inherit distutils-r1
  7. DESCRIPTION="real-time metrics for nginx server (and others)"
  8. HOMEPAGE="https://github.com/lebinh/ngxtop"
  9. #SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
  11. SLOT="0"
  12. LICENSE="MIT"
  13. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  14. IUSE=""
  15. RDEPEND="
  16. dev-python/docopt[${PYTHON_USEDEP}]
  17. dev-python/pyparsing[${PYTHON_USEDEP}]
  18. dev-python/tabulate[${PYTHON_USEDEP}]"
  19. DEPEND="${RDEPEND}
  20. "
  21. PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )