pwcrypt-1.2.2-r1.ebuild 600 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs
  5. DESCRIPTION="An improved version of cli-crypt (encrypts data sent to it from the cli)"
  6. HOMEPAGE="http://xjack.org/pwcrypt/"
  7. SRC_URI="http://xjack.org/pwcrypt/downloads/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DOCS=( CREDITS README )
  13. src_prepare() {
  14. sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile.in || die
  15. sed -i \
  16. -e "/^LDFLAGS/s/= /= @LDFLAGS@ /" \
  17. -e "/-install/s/ -s//" \
  18. src/Makefile.in || die
  19. tc-export CC
  20. }