yadm-1.05.ebuild 787 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A dotfile manager for the config files in your home folder"
  5. HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
  6. SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="test"
  11. DOCS=( CHANGES CONTRIBUTORS README.md )
  12. DEPEND="
  13. test? (
  14. dev-util/bats
  15. dev-vcs/git
  16. )"
  17. RDEPEND="dev-vcs/git
  18. app-crypt/gnupg"
  19. src_test() {
  20. # 109_accept_encryption tests are interactive, thus fail. Skip them
  21. bats $(find test/ -type f -name '*.bats' -and -not -name '109_accept_encryption.bats') \
  22. || die "Tests failed"
  23. }
  24. src_install() {
  25. einstalldocs
  26. dobin "${PN}"
  27. doman "${PN}.1"
  28. }