yadm-1.07.ebuild 895 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A dotfile manager for the config files in your home folder"
  5. HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
  6. SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="test"
  11. DOCS=( CHANGES CONTRIBUTORS README.md )
  12. DEPEND="
  13. test? (
  14. dev-tcltk/expect
  15. dev-util/bats
  16. dev-vcs/git
  17. )"
  18. RDEPEND="
  19. app-crypt/gnupg
  20. dev-vcs/git"
  21. src_compile() {
  22. emake yadm.md
  23. }
  24. src_test() {
  25. # 109_accept_encryption tests are interactive, thus fail. Skip them
  26. while IFS="" read -d $'\0' -r f ; do
  27. bats "${f}" || die "Test ${f} failed"
  28. done < <(find test -name '*.bats' -and -not -name '109_accept_encryption.bats' -print0)
  29. }
  30. src_install() {
  31. einstalldocs
  32. dobin "${PN}"
  33. doman "${PN}.1"
  34. }