afio-2.5.ebuild 927 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="Makes cpio-format archives and deals gracefully with input data corruption"
  5. HOMEPAGE="http://freshmeat.net/projects/afio/"
  6. SRC_URI="http://members.brabant.chello.nl/~k.holtman/${P}.tgz"
  7. LICENSE="Artistic LGPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 ~hppa ppc sparc x86"
  10. IUSE=""
  11. RDEPEND=""
  12. DEPEND="${RDEPEND}
  13. >=sys-apps/sed-4"
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. epatch "${FILESDIR}"/Makefile.patch
  18. # use our cflags
  19. sed -i \
  20. -e "s:-O2 -fomit-frame-pointer:${CFLAGS}:" \
  21. Makefile \
  22. || die "sed Makefile failed"
  23. }
  24. src_compile() {
  25. emake CC="$(tc-getCC)" || die "emake failed"
  26. }
  27. src_install() {
  28. local i
  29. dobin afio || die "dobin failed"
  30. dodoc ANNOUNCE-2.5 HISTORY README SCRIPTS
  31. for i in 1 2 3 4 5 ; do
  32. docinto script$i
  33. dodoc script$i/*
  34. done
  35. doman afio.1
  36. }