dar-2.5.9.ebuild 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic
  5. DESCRIPTION="A full featured backup tool, aimed for disks"
  6. HOMEPAGE="http://dar.linux.free.fr/"
  7. SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
  11. IUSE="dar32 dar64 doc gcrypt gpg lzo nls static static-libs xattr"
  12. RESTRICT="test" # need to be run as root
  13. RDEPEND=">=sys-libs/zlib-1.2.3:=
  14. !static? (
  15. app-arch/bzip2:=
  16. app-arch/xz-utils:=
  17. sys-libs/libcap
  18. gcrypt? ( dev-libs/libgcrypt:0= )
  19. gpg? ( app-crypt/gpgme )
  20. lzo? ( dev-libs/lzo:= )
  21. xattr? ( sys-apps/attr:= )
  22. )"
  23. DEPEND="${RDEPEND}
  24. static? (
  25. app-arch/bzip2[static-libs]
  26. app-arch/xz-utils[static-libs]
  27. sys-libs/libcap[static-libs]
  28. sys-libs/zlib[static-libs]
  29. gcrypt? ( dev-libs/libgcrypt:0=[static-libs] )
  30. gpg? (
  31. app-crypt/gpgme[static-libs]
  32. dev-libs/libassuan[static-libs]
  33. dev-libs/libgpg-error[static-libs]
  34. )
  35. lzo? ( dev-libs/lzo[static-libs] )
  36. xattr? ( sys-apps/attr[static-libs] )
  37. )
  38. nls? (
  39. sys-devel/gettext
  40. virtual/libintl
  41. )
  42. doc? ( app-doc/doxygen )"
  43. REQUIRED_USE="?? ( dar32 dar64 )
  44. gpg? ( gcrypt )"
  45. #PATCHES=(
  46. #)
  47. src_configure() {
  48. local myconf=( --disable-upx )
  49. # Bug 103741
  50. filter-flags -fomit-frame-pointer
  51. # configure.ac is totally funked up regarding the AC_ARG_ENABLE
  52. # logic.
  53. # For example "--enable-dar-static" causes configure to DISABLE
  54. # static builds of dar.
  55. # Do _not_ use $(use_enable) until you have verified that the
  56. # logic has been fixed by upstream.
  57. use xattr || myconf+=( --disable-ea-support )
  58. use dar32 && myconf+=( --enable-mode=32 )
  59. use dar64 && myconf+=( --enable-mode=64 )
  60. use doc || myconf+=( --disable-build-html )
  61. # use examples && myconf+=( --enable-examples )
  62. use gcrypt || myconf+=( --disable-libgcrypt-linking )
  63. use gpg || myconf+=( --disable-gpgme-linking )
  64. use lzo || myconf+=( --disable-liblzo2-linking )
  65. use nls || myconf+=( --disable-nls )
  66. if ! use static ; then
  67. myconf+=( --disable-dar-static )
  68. if ! use static-libs ; then
  69. myconf+=( --disable-static )
  70. fi
  71. fi
  72. econf ${myconf[@]}
  73. }
  74. src_install() {
  75. emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
  76. local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
  77. einstalldocs
  78. if ! use static-libs ; then
  79. prune_libtool_files --all
  80. fi
  81. }