dirvish-1.2.1.ebuild 925 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="Dirvish is a fast, disk based, rotating network backup system"
  4. HOMEPAGE="http://www.dirvish.org/"
  5. SRC_URI="http://dirvish.org/${P}.tgz"
  6. LICENSE="OSL-2.0"
  7. SLOT="0"
  8. KEYWORDS="amd64 ppc x86"
  9. IUSE=""
  10. DEPEND="app-arch/tar"
  11. RDEPEND="dev-perl/Time-ParseDate
  12. dev-perl/Time-Period
  13. >=net-misc/rsync-2.5.7"
  14. src_compile() {
  15. for f in dirvish dirvish-runall dirvish-expire dirvish-locate ; do
  16. cat > $f <<-EOF
  17. #!/usr/bin/perl
  18. \$CONFDIR = "/etc/dirvish";
  19. EOF
  20. cat $f.pl >> $f
  21. cat loadconfig.pl >> $f
  22. done
  23. }
  24. src_install() {
  25. dosbin dirvish dirvish-runall dirvish-expire dirvish-locate
  26. doman dirvish.8 dirvish-runall.8 dirvish-expire.8 dirvish-locate.8 dirvish.conf.5
  27. dohtml FAQ.html INSTALL RELEASE.html TODO.html
  28. dodoc CHANGELOG
  29. insinto /etc/dirvish; doins "${FILESDIR}"/master.conf.example
  30. }