fsarchiver-0.8.0.ebuild 897 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Flexible filesystem archiver for backup and deployment tool"
  6. HOMEPAGE="http://www.fsarchiver.org"
  7. SRC_URI="https://github.com/fdupoux/${PN}/releases/download/${PV}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug lzma lzo static"
  12. DEPEND="dev-libs/libgcrypt:0=
  13. >=sys-fs/e2fsprogs-1.41.4
  14. lzma? ( >=app-arch/xz-utils-4.999.9_beta )
  15. lzo? ( >=dev-libs/lzo-2.02 )
  16. static? ( lzma? ( app-arch/xz-utils[static-libs] ) )"
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. default
  20. sed -i -e 's/^\([a-z]*_CFLAGS.*\)-ggdb/\1/' src/Makefile.am \
  21. || die "seding failed"
  22. eautoreconf
  23. }
  24. src_configure() {
  25. myeconfargs=(
  26. $(use_enable lzma)
  27. $(use_enable lzo)
  28. $(use_enable static)
  29. $(use_enable debug devel)
  30. )
  31. econf "${myeconfargs[@]}"
  32. }