rdup-1.1.15.ebuild 856 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils autotools
  5. DESCRIPTION="Generate a file list suitable for full or incremental backups"
  6. HOMEPAGE="https://github.com/miekg/rdup/releases"
  7. SRC_URI="https://github.com/miekg/rdup/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug test"
  12. RDEPEND="
  13. app-arch/libarchive
  14. dev-libs/glib:2
  15. dev-libs/libpcre
  16. dev-libs/nettle"
  17. DEPEND="${RDEPEND}
  18. test? ( dev-util/dejagnu )"
  19. src_prepare() {
  20. default_src_prepare
  21. sed -i -e 's/ -Werror//' GNUmakefile.in || die "Failed to fix Makefile"
  22. eautoreconf
  23. }
  24. src_configure() {
  25. econf $(use_enable debug)
  26. }
  27. src_test() {
  28. if use debug; then
  29. ewarn "Test phase skipped, as it is known to fail with USE=\"debug\"."
  30. else
  31. default_src_test
  32. fi
  33. }