rear-1.17.1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="A setup-and-forget Linux bare metal disaster recovery solution"
  6. HOMEPAGE="http://relax-and-recover.org/"
  7. MY_PV=${PV%.*}
  8. SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${MY_PV}/${PV}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="libressl udev"
  13. RDEPEND="
  14. !libressl? ( dev-libs/openssl:0= )
  15. libressl? ( dev-libs/libressl:0= )
  16. net-dialup/mingetty
  17. net-fs/nfs-utils
  18. sys-apps/gawk
  19. sys-apps/iproute2
  20. sys-apps/lsb-release
  21. sys-apps/util-linux
  22. sys-block/parted
  23. sys-boot/syslinux
  24. virtual/cdrtools
  25. udev? ( virtual/udev )
  26. "
  27. src_compile () { :; }
  28. src_install () {
  29. # Deploy udev USB rule and udev will autostart ReaR workflows in case a USB
  30. # drive with the label 'REAR_000' is connected, which in turn is the
  31. # default label when running the `rear format` command.
  32. if use udev ; then
  33. insinto /lib/udev/rules.d
  34. doins etc/udev/rules.d/62-${PN}-usb.rules
  35. fi
  36. # Copy main script-file and documentation.
  37. dosbin usr/sbin/${PN}
  38. doman doc/${PN}.8
  39. dodoc README
  40. # Copy configurations files.
  41. insinto /etc
  42. doins -r etc/${PN}/
  43. insinto /usr/share/
  44. doins -r usr/share/${PN}/
  45. }