reoback-1.0_p3-r1.ebuild 977 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Reoback Backup Solution"
  6. HOMEPAGE="http://reoback.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/reoback/reoback-${PV/_p/_r}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. RDEPEND=">=dev-lang/perl-5.6.1"
  13. DEPEND=">=app-arch/tar-1.13"
  14. S=${WORKDIR}/${PN}-${PV/_*}
  15. src_prepare() {
  16. ecvs_clean
  17. sed \
  18. -e '/^config=/s:=.*:=/etc/reoback/settings.conf:' \
  19. -e '/^reoback=/s:=.*:=/usr/sbin/reoback.pl:' \
  20. -i run_reoback.sh || die
  21. }
  22. src_install() {
  23. dosbin reoback.pl
  24. insinto /etc/reoback
  25. doins conf/*
  26. fperms o-x /usr/sbin/reoback.pl
  27. insinto /etc/cron.daily
  28. newins run_reoback.sh reoback
  29. dodoc docs/{BUGS,CHANGES,INSTALL,MANUALS,README,TODO}
  30. }
  31. pkg_postinst() {
  32. elog "Reoback can now be activated by simply configuring the files in"
  33. elog "/etc/reoback and then doing: chmod +x /etc/cron.daily/reoback"
  34. }