rsnapshot-1.4.1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A filesystem backup utility based on rsync"
  6. HOMEPAGE="http://www.rsnapshot.org"
  7. SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="alpha amd64 ~ppc ~ppc64 ~sparc ~x86"
  11. RDEPEND=">=dev-lang/perl-5.8.2
  12. dev-perl/Lchown
  13. >=sys-apps/util-linux-2.12-r4
  14. >=sys-apps/coreutils-5.0.91-r4
  15. >=net-misc/openssh-3.7.1_p2-r1
  16. >=net-misc/rsync-2.6.0"
  17. DEPEND="${RDEPEND}"
  18. src_install() {
  19. # Change sysconfdir to install the template file as documentation
  20. # rather than in /etc.
  21. emake install DESTDIR="${D}" \
  22. sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
  23. dodoc README.md AUTHORS ChangeLog \
  24. docs/Upgrading_from_1.1
  25. docinto utils
  26. dodoc utils/{README,rsnaptar,*.sh,*.pl}
  27. docinto utils/rsnapshotdb
  28. dodoc utils/rsnapshotdb/*
  29. }
  30. pkg_postinst() {
  31. elog "The template configuration file has been installed as"
  32. elog "/usr/share/doc/${PF}/rsnapshot.conf.default"
  33. elog "Copy and edit the the above file as /etc/rsnapshot.conf"
  34. }