filebench-1.4.9.1-r1.ebuild 667 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Filebench - A Model Based File System Workload Generator"
  6. HOMEPAGE="https://sourceforge.net/projects/filebench/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="CDDL"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="auto-completion"
  12. RDEPEND="
  13. auto-completion? ( dev-libs/libtecla )
  14. "
  15. DEPEND="${RDEPEND}
  16. sys-devel/flex
  17. sys-devel/bison
  18. "
  19. PATCHES=( "${FILESDIR}"/${PN}-fix-automagic-libtecla-dependency.patch )
  20. src_prepare() {
  21. default
  22. eautoreconf
  23. }
  24. src_configure() {
  25. econf $(use_with auto-completion libtecla)
  26. }