cdrdao-1.2.3-r3.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools flag-o-matic
  5. DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
  6. HOMEPAGE="http://cdrdao.sourceforge.net/"
  7. if [[ ${PV/*_rc*} ]]
  8. then
  9. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
  10. else
  11. SRC_URI="http://www.poolshark.org/src/${P/_}.tar.bz2"
  12. fi
  13. LICENSE="GPL-2"
  14. SLOT="0"
  15. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
  16. IUSE="gcdmaster encode mad vorbis"
  17. RDEPEND="virtual/cdrtools
  18. encode? ( >=media-sound/lame-3.99 )
  19. gcdmaster? (
  20. >=dev-libs/libsigc++-2.6:2
  21. >=dev-cpp/gtkmm-2.4:2.4
  22. >=dev-cpp/libgnomeuimm-2.6:2.6
  23. media-libs/libao
  24. )
  25. mad? (
  26. media-libs/libmad
  27. media-libs/libao
  28. )
  29. vorbis? (
  30. media-libs/libvorbis
  31. media-libs/libao
  32. )
  33. !app-cdr/cue2toc
  34. !dev-util/pccts"
  35. DEPEND="${RDEPEND}
  36. virtual/pkgconfig"
  37. PATCHES=(
  38. "${FILESDIR}/${P}-glibc212.patch"
  39. "${FILESDIR}/${P}-unsigned-char.patch"
  40. "${FILESDIR}/${P}-ax_pthread.patch"
  41. "${FILESDIR}/${P}-wformat-security.patch"
  42. )
  43. S=${WORKDIR}/${P/_}
  44. src_prepare() {
  45. default
  46. eautoreconf
  47. }
  48. src_configure() {
  49. # Fix building with latest libsigc++
  50. append-cxxflags -std=c++11
  51. find -name '*.h' -exec sed -i '/sigc++\/object.h/d' {} + || die
  52. econf \
  53. $(use_with gcdmaster xdao) \
  54. $(use_with vorbis ogg-support) \
  55. $(use_with mad mp3-support) \
  56. $(use_with encode lame)
  57. }