gtkcdlabel-1.14-r1.ebuild 788 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="A GUI for cdlabelgen that generates CD labels"
  7. HOMEPAGE="http://gtkcdlabel.sourceforge.net"
  8. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc ~sparc x86"
  12. IUSE=""
  13. DEPEND="${PYTHON_DEPS}
  14. >=app-cdr/cdlabelgen-4
  15. dev-python/pygtk[${PYTHON_USEDEP}]"
  16. RDEPEND="${DEPEND}"
  17. REQUIRED_USE=${PYTHON_REQUIRED_USE}
  18. S=${WORKDIR}
  19. src_prepare() {
  20. python_fix_shebang .
  21. }
  22. src_install() {
  23. dobin usr/bin/${PN}.py || die "dobin failed"
  24. insinto /usr/share
  25. doins -r usr/share/{applications,${PN},pixmaps} || die "doins failed"
  26. dodoc usr/share/doc/${PN}/{AUTHORS,README}
  27. }