dictd-vera-1.23.ebuild 887 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
  5. HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
  6. SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
  7. SLOT="0"
  8. LICENSE="FDL-1.3"
  9. KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
  10. DEPEND=">=app-text/dictd-1.5.5"
  11. RDEPEND="${DEPEND}"
  12. S=${WORKDIR}/vera-${PV}
  13. src_compile () {
  14. # sed -f debian/dict-vera/sedfile vera.? >vera1 || die
  15. # sed '1,2!s/^/ /' vera. > vera || die
  16. # cat vera1>>vera || die
  17. cat vera.[0-9a-z] | /usr/bin/dictfmt -f -u http://home.snafu.de/ohei \
  18. -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
  19. vera || die
  20. /usr/bin/dictzip -v vera.dict || die
  21. }
  22. src_install () {
  23. dodir /usr/lib/dict
  24. insinto /usr/lib/dict
  25. doins vera.dict.dz
  26. doins vera.index
  27. dodoc changelog README
  28. }