gnome-dictionary-3.20.0.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="Dictionary utility for GNOME"
  6. HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
  7. LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
  8. SLOT="0/10" # subslot = suffix of libgdict-1.0.so
  9. IUSE="debug +introspection ipv6"
  10. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. COMMON_DEPEND="
  12. >=dev-libs/glib-2.39:2[dbus]
  13. x11-libs/cairo:=
  14. >=x11-libs/gtk+-3.20:3
  15. x11-libs/pango
  16. introspection? ( >=dev-libs/gobject-introspection-1.42:= )
  17. "
  18. RDEPEND="${COMMON_DEPEND}
  19. gnome-base/gsettings-desktop-schemas
  20. !<gnome-extra/gnome-utils-3.4
  21. "
  22. # ${PN} was part of gnome-utils before 3.4
  23. DEPEND="${COMMON_DEPEND}
  24. >=dev-util/gtk-doc-am-1.15
  25. >=dev-util/intltool-0.40
  26. dev-util/itstool
  27. >=sys-devel/gettext-0.17
  28. virtual/pkgconfig
  29. "
  30. src_configure() {
  31. gnome2_src_configure \
  32. $(usex debug --enable-debug=yes ' ') \
  33. $(use_enable introspection) \
  34. $(use_enable ipv6)
  35. }