gwaei-3.6.2.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit gnome2-utils eutils
  5. DESCRIPTION="Japanese-English Dictionary for GNOME"
  6. HOMEPAGE="http://gwaei.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/gwaei/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gtk hunspell nls test mecab"
  12. RDEPEND=">=net-misc/curl-7.20.0
  13. >=dev-libs/glib-2.31
  14. gtk? (
  15. x11-libs/gtk+:3
  16. >=app-text/gnome-doc-utils-0.14.0
  17. )
  18. hunspell? ( app-text/hunspell )
  19. nls? ( virtual/libintl )
  20. mecab? ( app-text/mecab )"
  21. DEPEND="${RDEPEND}
  22. test? (
  23. app-text/docbook-xml-dtd:4.1.2
  24. app-text/scrollkeeper-dtd
  25. )
  26. gtk? (
  27. x11-themes/gnome-icon-theme-symbolic
  28. >=app-text/gnome-doc-utils-0.14.0
  29. )
  30. nls? ( >=sys-devel/gettext-0.17 )
  31. app-text/rarian
  32. dev-util/intltool
  33. virtual/pkgconfig"
  34. src_configure() {
  35. econf \
  36. $(use_with gtk gnome) \
  37. $(use_enable nls) \
  38. $(use_with hunspell) \
  39. $(use_with mecab) \
  40. --disable-static \
  41. --docdir=/usr/share/doc/${PF}
  42. }
  43. src_install() {
  44. emake DESTDIR="${D}" install || die
  45. find "${D}" -name '*.la' -delete
  46. dodoc AUTHORS README
  47. }
  48. pkg_preinst() {
  49. if use gtk ; then
  50. gnome2_schemas_savelist
  51. fi
  52. }
  53. pkg_postinst() {
  54. if use gtk ; then
  55. gnome2_schemas_update
  56. fi
  57. }
  58. pkg_postrm() {
  59. if use gtk ; then
  60. gnome2_schemas_update
  61. fi
  62. }