devmanual-9999.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit git-2 readme.gentoo
  5. DESCRIPTION="The Gentoo Development Guide"
  6. HOMEPAGE="https://devmanual.gentoo.org/"
  7. EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
  8. LICENSE="CC-BY-SA-2.0"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE=""
  12. DEPEND="dev-libs/libxslt
  13. media-gfx/imagemagick[truetype,svg,png]"
  14. DOC_CONTENTS="In order to browse the Gentoo Development Guide in
  15. offline mode, point your browser to the following url:
  16. /usr/share/doc/devmanual/html/index.html"
  17. src_compile() {
  18. # Imagemagick uses inkscape (if present) to delegate
  19. # svg conversions.
  20. # Inkscape uses g_get_user_config_dir () which in turn
  21. # uses XDG_CONFIG_HOME to get the config directory for this
  22. # user. See bug 463380
  23. export XDG_CONFIG_HOME="${T}/inkscape_home"
  24. emake
  25. }
  26. src_install() {
  27. dohtml -r *
  28. einfo "Creating symlink from ${P} to ${PN} for preserving bookmarks"
  29. dosym /usr/share/doc/${P} /usr/share/doc/${PN}
  30. readme.gentoo_create_doc
  31. }
  32. pkg_postinst() {
  33. readme.gentoo_print_elog
  34. if ! has_version app-portage/eclass-manpages; then
  35. elog "The offline version of the devmanual does not include the"
  36. elog "documentation for the eclasses. If you need it, then emerge"
  37. elog "the following package:"
  38. elog
  39. elog "app-portage/eclass-manpages"
  40. elog
  41. fi
  42. }