halibut-1.0.ebuild 717 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs
  4. DESCRIPTION="yet another free document preparation system"
  5. HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/halibut/"
  6. SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc x86"
  10. IUSE=""
  11. src_compile() {
  12. tc-export CC
  13. CFLAGS="${CFLAGS} ${CPPFLAGS}" \
  14. LFLAGS="${LDFLAGS}" \
  15. emake -j1 \
  16. BUILDDIR="${S}/build" \
  17. VERSION="${PV}" \
  18. || die "make failed"
  19. emake -C doc || die "make in doc failed"
  20. }
  21. src_install() {
  22. dobin build/halibut || die
  23. doman doc/halibut.1 || die
  24. dodoc doc/halibut.txt
  25. dohtml doc/*.html
  26. }