beaver-0.4.1.ebuild 926 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils gnome2-utils
  5. DESCRIPTION="Beaver is an Early AdVanced EditoR"
  6. HOMEPAGE="http://beaver-editor.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/beaver-editor/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug doc"
  12. RDEPEND=">=dev-libs/glib-2.14:2
  13. >=x11-libs/gtk+-2.10:2"
  14. DEPEND="${RDEPEND}
  15. doc? ( app-doc/doxygen )
  16. virtual/pkgconfig
  17. dev-util/intltool
  18. sys-devel/gettext"
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${PN}-0.4.1-desktop-file-validate.patch
  21. }
  22. src_configure() {
  23. econf \
  24. $(use_enable doc doxygen-doc) \
  25. $(use_enable debug)
  26. }
  27. DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
  28. src_install() {
  29. default
  30. prune_libtool_files
  31. }
  32. pkg_preinst() {
  33. gnome2_icon_savelist
  34. }
  35. pkg_postinst() {
  36. gnome2_icon_cache_update
  37. }
  38. pkg_postrm() {
  39. gnome2_icon_cache_update
  40. }