bvi-1.3.2-r2.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. AUTOTOOLS_AUTORECONF="1"
  5. AUTOTOOLS_IN_SOURCE_BUILD="1"
  6. inherit multilib eutils autotools-utils
  7. DESCRIPTION="display-oriented editor for binary files, based on the vi texteditor"
  8. HOMEPAGE="http://bvi.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/bvi/${P}.src.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. IUSE=""
  13. KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
  14. DEPEND="sys-libs/ncurses"
  15. RDEPEND="${DEPEND}"
  16. src_prepare() {
  17. local PATCHES=(
  18. "${FILESDIR}/${P}-fix-buffer-overflow.patch"
  19. "${FILESDIR}/${P}-tinfo.patch"
  20. )
  21. sed -i -e 's:ncurses/term.h:term.h:g' bmore.h || die "sed failed in bmore.h"
  22. sed -i -e 's:(INSTALL_PROGRAM) -s:(INSTALL_PROGRAM):g' \
  23. Makefile.in || die "sed failed in Makefile.in"
  24. autotools-utils_src_prepare
  25. }
  26. src_configure() {
  27. local myeconfargs=(--with-ncurses="${EPREFIX}"/usr)
  28. autotools-utils_src_configure
  29. }
  30. src_install() {
  31. autotools-utils_src_install
  32. rm -rf "${ED}"/usr/$(get_libdir)/bmore.help
  33. dodoc README CHANGES CREDITS bmore.help
  34. dohtml -r html/*
  35. }