e3-2.8.ebuild 759 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Very tiny editor in ASM with emacs, pico, wordstar, and vi keybindings"
  5. HOMEPAGE="https://sites.google.com/site/e3editor/"
  6. SRC_URI="https://sites.google.com/site/e3editor/Home/${P}.tgz"
  7. LICENSE="GPL-2+"
  8. SLOT="0"
  9. KEYWORDS="-* amd64 x86"
  10. RESTRICT="strip"
  11. DEPEND=">=dev-lang/nasm-2.09.04"
  12. RDEPEND=""
  13. src_prepare() {
  14. sed -i 's/-D$(EXMODE)//' Makefile || die
  15. }
  16. src_compile() {
  17. emake -- $(usex amd64 64 32)
  18. }
  19. src_install() {
  20. dobin e3
  21. dosym e3 /usr/bin/e3em
  22. dosym e3 /usr/bin/e3ne
  23. dosym e3 /usr/bin/e3pi
  24. dosym e3 /usr/bin/e3vi
  25. dosym e3 /usr/bin/e3ws
  26. newman e3.man e3.1
  27. dohtml e3.html
  28. dodoc ChangeLog README README_OLD
  29. }