12345678910111213141516171819202122232425262728293031323334353637383940 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="4"
- inherit toolchain-funcs
- DESCRIPTION="An easy to use text editor. Intended to be usable with little or no instruction"
- HOMEPAGE="http://mahon.cwx.net/"
- SRC_URI="http://mahon.cwx.net/sources/${P}.src.tgz"
- LICENSE="Artistic"
- SLOT="0"
- KEYWORDS="~amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
- IUSE=""
- RDEPEND="!app-editors/ersatz-emacs"
- S="${WORKDIR}/easyedit-${PV}"
- src_prepare() {
- sed -i \
- -e "s/\tcc /\t\\\\\$(CC) /" \
- -e "/other_cflag/s/ *-s//" \
- create.make
- }
- src_configure() {
- emake localmake
- }
- src_compile() {
- emake -f make.local CC="$(tc-getCC)"
- }
- src_install() {
- dobin ee
- doman ee.1
- dodoc Changes README.ee ee.i18n.guide ee.msg
- }
|