gedit-3.22.0.ebuild 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. GNOME2_LA_PUNT="yes" # plugins are dlopened
  5. PYTHON_COMPAT=( python3_{4,5} )
  6. VALA_MIN_API_VERSION="0.26"
  7. VALA_USE_DEPEND="vapigen"
  8. inherit eutils gnome2 multilib python-single-r1 vala virtualx
  9. DESCRIPTION="A text editor for the GNOME desktop"
  10. HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
  11. LICENSE="GPL-2+ CC-BY-SA-3.0"
  12. SLOT="0"
  13. IUSE="+introspection +python spell vala"
  14. REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
  15. KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
  16. # X libs are not needed for OSX (aqua)
  17. COMMON_DEPEND="
  18. >=dev-libs/libxml2-2.5.0:2
  19. >=dev-libs/glib-2.44:2[dbus]
  20. >=x11-libs/gtk+-3.21.3:3[introspection?]
  21. >=x11-libs/gtksourceview-3.21.2:3.0[introspection?]
  22. >=dev-libs/libpeas-1.14.1[gtk]
  23. gnome-base/gsettings-desktop-schemas
  24. gnome-base/gvfs
  25. x11-libs/libX11
  26. introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
  27. python? (
  28. ${PYTHON_DEPS}
  29. dev-python/pycairo[${PYTHON_USEDEP}]
  30. >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
  31. dev-libs/libpeas[${PYTHON_USEDEP}] )
  32. spell? ( >=app-text/gspell-0.2.5:0= )
  33. "
  34. RDEPEND="${COMMON_DEPEND}
  35. x11-themes/adwaita-icon-theme
  36. "
  37. DEPEND="${COMMON_DEPEND}
  38. ${vala_depend}
  39. app-text/docbook-xml-dtd:4.1.2
  40. app-text/yelp-tools
  41. >=dev-util/gtk-doc-am-1
  42. >=dev-util/intltool-0.50.1
  43. >=sys-devel/gettext-0.18
  44. virtual/pkgconfig
  45. "
  46. # yelp-tools, gnome-common needed to eautoreconf
  47. pkg_setup() {
  48. use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
  49. }
  50. src_prepare() {
  51. vala_src_prepare
  52. gnome2_src_prepare
  53. }
  54. src_configure() {
  55. DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
  56. gnome2_src_configure \
  57. --disable-deprecations \
  58. --disable-updater \
  59. --enable-gvfs-metadata \
  60. $(use_enable introspection) \
  61. $(use_enable spell) \
  62. $(use_enable python) \
  63. $(use_enable vala)
  64. }
  65. src_test() {
  66. "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
  67. GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
  68. }
  69. src_install() {
  70. local args=()
  71. # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
  72. use python && args+=( pyoverridesdir="$(python_get_sitedir)/gi/overrides" )
  73. gnome2_src_install "${args[@]}"
  74. }