gummi-0.6.6.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils
  5. DESCRIPTION="Simple LaTeX editor for GTK+ users"
  6. HOMEPAGE="https://github.com/alexandervdm/gummi"
  7. SRC_URI="https://github.com/alexandervdm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. LANGS="ar ca cs da de el es fr hu it nl pl pt pt_BR ro ru sv zh_CN zh_TW"
  13. for X in ${LANGS} ; do
  14. IUSE="${IUSE} linguas_${X}"
  15. done
  16. RDEPEND="
  17. dev-libs/glib:2
  18. dev-texlive/texlive-latex
  19. dev-texlive/texlive-latexextra
  20. x11-libs/gtk+:2"
  21. DEPEND="${RDEPEND}
  22. app-text/gtkspell:2
  23. app-text/poppler[cairo]
  24. x11-libs/gtksourceview:2.0
  25. x11-libs/pango"
  26. DOCS=( AUTHORS ChangeLog README.md )
  27. src_prepare() {
  28. strip-linguas ${LANGS}
  29. eautoreconf
  30. default
  31. }
  32. pkg_postinst() {
  33. elog "Gummi supports spell-checking through gtkspell. Support for"
  34. elog "additional languages can be added by installing myspell-**-"
  35. elog "packages for your language of choice."
  36. }