kakoune-9999.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic toolchain-funcs git-r3 versionator
  5. DESCRIPTION="Selection-oriented code editor inspired by vim"
  6. HOMEPAGE="https://github.com/mawww/kakoune"
  7. EGIT_REPO_URI="https://github.com/mawww/kakoune.git"
  8. LICENSE="Unlicense"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE="debug static"
  12. RDEPEND="
  13. sys-libs/ncurses:0=[unicode]
  14. dev-libs/boost:=
  15. "
  16. DEPEND="
  17. app-text/asciidoc
  18. virtual/pkgconfig
  19. ${RDEPEND}
  20. "
  21. PATCHES=( "${FILESDIR}/${PN}-0_pre20161111-makefile.patch" )
  22. pkg_setup() {
  23. if [[ ${MERGE_TYPE} != binary ]]; then
  24. if tc-is-gcc && ! version_is_at_least 5.0 $(gcc-version); then
  25. die "Clang or GCC >=5.0 is required to build this version"
  26. fi
  27. fi
  28. }
  29. src_configure() {
  30. append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
  31. append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
  32. tc-export CXX
  33. export debug=$(usex debug)
  34. export static=$(usex static)
  35. }
  36. src_install() {
  37. emake -C src DESTDIR="${D}" PREFIX="${EPREFIX}/usr" docdir="${ED%/}/usr/share/doc/${PF}" install
  38. }