pluma-1.16.0-r1.ebuild 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. PYTHON_COMPAT=( python2_7 )
  6. inherit mate multilib python-single-r1 virtualx
  7. if [[ ${PV} != 9999 ]]; then
  8. KEYWORDS="~amd64 ~arm ~x86"
  9. fi
  10. DESCRIPTION="Pluma text editor for the MATE desktop"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. IUSE="gtk3 python spell"
  14. REQUIRED_USE="
  15. gtk3? ( !python )
  16. python? ( ${PYTHON_REQUIRED_USE} )"
  17. # Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
  18. # https://github.com/mate-desktop/mate-text-editor/issues/33
  19. RESTRICT="test"
  20. COMMON_DEPEND="dev-libs/atk:0
  21. >=dev-libs/glib-2.36:2
  22. >=dev-libs/libxml2-2.5:2
  23. x11-libs/cairo:0
  24. x11-libs/gdk-pixbuf:2
  25. x11-libs/libICE:0
  26. x11-libs/libX11:0
  27. >=x11-libs/libSM-1.0
  28. x11-libs/pango:0
  29. virtual/libintl:0
  30. !gtk3? (
  31. >=x11-libs/gtk+-2.24:2
  32. >=x11-libs/gtksourceview-2.9.7:2.0
  33. )
  34. gtk3? (
  35. >=x11-libs/gtk+-3.0:3
  36. >=x11-libs/gtksourceview-2.9.7:3.0
  37. )
  38. spell? (
  39. >=app-text/enchant-1.2:0
  40. >=app-text/iso-codes-0.35:0
  41. )
  42. python? (
  43. ${PYTHON_DEPS}
  44. >=dev-python/pygobject-2.15.4:2[${PYTHON_USEDEP}]
  45. >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
  46. >=dev-python/pygtksourceview-2.9.2:2
  47. )
  48. !!app-editors/mate-text-editor"
  49. RDEPEND="${COMMON_DEPEND}
  50. >=mate-base/mate-desktop-1.9[gtk3(-)=]"
  51. DEPEND="${COMMON_DEPEND}
  52. ~app-text/docbook-xml-dtd-4.1.2
  53. app-text/rarian:0
  54. >=app-text/scrollkeeper-dtd-1:1.0
  55. app-text/yelp-tools:0
  56. dev-util/gtk-doc
  57. dev-util/gtk-doc-am
  58. >=dev-util/intltool-0.50.1:*
  59. >=sys-devel/libtool-2.2.6:2
  60. >=sys-devel/gettext-0.17:*
  61. virtual/pkgconfig:*"
  62. pkg_setup() {
  63. use python && python-single-r1_pkg_setup
  64. }
  65. src_configure() {
  66. mate_src_configure \
  67. --with-gtk=$(usex gtk3 3.0 2.0) \
  68. $(use_enable python) \
  69. $(use_enable spell)
  70. }
  71. src_test() {
  72. # FIXME: This should be handled at eclass level.
  73. "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
  74. unset DBUS_SESSION_BUS_ADDRESS
  75. GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
  76. }