yudit-2.9.2.ebuild 774 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="Free (Y)unicode text editor for all unices"
  5. HOMEPAGE="http://www.yudit.org/"
  6. SRC_URI="http://yudit.org/download/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. RDEPEND="x11-libs/libX11"
  11. DEPEND="${RDEPEND}
  12. >=sys-devel/gettext-0.10"
  13. src_prepare() {
  14. #Don't strip binaries, let portage do that.
  15. sed -i "/^INSTALL_PROGRAM/s: -s::" Makefile.conf.in || die "sed failed"
  16. }
  17. src_compile() {
  18. #FIXME:
  19. #-j1 because this app builds a tool called 'mytool' and we need to make
  20. #sure that it is built before it needs to be used.
  21. emake -j1
  22. }
  23. src_install() {
  24. make DESTDIR="${D}" install || die
  25. dodoc {BUGS,CHANGELOG,NEWS,TODO,XBUGS}.TXT
  26. }