libvirt-glib-1.0.0.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. GCONF_DEBUG="no"
  5. GNOME2_LA_PUNT="yes"
  6. PYTHON_COMPAT=( python2_7 )
  7. inherit gnome2 python-single-r1 vala
  8. DESCRIPTION="GLib and GObject mappings for libvirt"
  9. HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
  10. SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
  11. LICENSE="LGPL-2.1"
  12. SLOT="0"
  13. KEYWORDS="amd64 x86"
  14. IUSE="+introspection nls python +vala"
  15. REQUIRED_USE="
  16. python? ( ${PYTHON_REQUIRED_USE} )
  17. vala? ( introspection )
  18. "
  19. # https://bugzilla.redhat.com/show_bug.cgi?id=1093633
  20. RESTRICT="test"
  21. RDEPEND="
  22. dev-libs/libxml2:2
  23. >=app-emulation/libvirt-1.2.6:=
  24. >=dev-libs/glib-2.38.0:2
  25. introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
  26. python? ( ${PYTHON_DEPS} )
  27. "
  28. DEPEND="${RDEPEND}
  29. dev-util/gtk-doc-am
  30. >=dev-util/intltool-0.35.0
  31. virtual/pkgconfig
  32. vala? ( $(vala_depend) )
  33. "
  34. pkg_setup() {
  35. use python && python-single-r1_pkg_setup
  36. }
  37. src_prepare() {
  38. gnome2_src_prepare
  39. use vala && vala_src_prepare
  40. }
  41. src_configure() {
  42. gnome2_src_configure \
  43. --disable-test-coverage \
  44. --disable-static \
  45. $(use_enable introspection) \
  46. $(use_enable nls) \
  47. $(use_enable vala) \
  48. $(use_with python)
  49. }