openstack-guest-agents-unix-1.39.0.ebuild 610 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils vcs-snapshot
  5. DESCRIPTION="Openstack Unix Guest Agent"
  6. HOMEPAGE="https://github.com/rackerlabs/openstack-guest-agents-unix"
  7. SRC_URI="https://github.com/rackerlabs/${PN}/tarball/v${PV} -> ${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. DEPEND="
  13. dev-util/patchelf
  14. dev-python/pycrypto
  15. dev-python/pyxenstore
  16. "
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. eautoreconf
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" install
  23. doinitd scripts/gentoo/nova-agent
  24. }