softgun-0.21.ebuild 611 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="ARM software emulator"
  6. HOMEPAGE="http://softgun.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE=""
  12. src_prepare() {
  13. epatch "${FILESDIR}"/${PN}-0.21-make.patch
  14. sed -i \
  15. -e "/^CFLAGS/s:-O9.*-Werror:${CFLAGS}:" \
  16. config.mk || die
  17. }
  18. src_compile() {
  19. emake CC="$(tc-getCC)"
  20. }
  21. src_install() {
  22. dodir /usr/bin
  23. emake install prefix="${D}/usr"
  24. dodoc README configs/*.sg
  25. }