123456789101112131415161718192021222324252627282930313233343536 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils
- DESCRIPTION="gnat module for eselect"
- HOMEPAGE="https://www.gentoo.org"
- SRC_URI=""
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 ppc x86"
- IUSE=""
- RDEPEND="app-admin/eselect"
- S="${WORKDIR}"
- MODULEDIR="/usr/share/eselect/modules"
- # NOTE!!
- # This path is duplicated in gnat-eselect module,
- # adjust in both locations!
- LIBDIR="/usr/share/gnat/lib"
- src_install() {
- dodir ${MODULEDIR}
- insinto ${MODULEDIR}
- newins "${FILESDIR}"/gnat.eselect-${PV} gnat.eselect
- dodir ${LIBDIR}
- insinto ${LIBDIR}
- newins "${FILESDIR}"/gnat-common-${PVR}.bash gnat-common.bash
- }
|