eselect-gnat-1.5.ebuild 808 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="gnat module for eselect"
  6. HOMEPAGE="https://www.gentoo.org"
  7. SRC_URI=""
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~sparc"
  11. IUSE=""
  12. RDEPEND=">=app-admin/eselect-1.2.5"
  13. S="${WORKDIR}"
  14. MODULEDIR="/usr/share/eselect/modules"
  15. # NOTE!!
  16. # This path is duplicated in gnat-eselect module,
  17. # adjust in both locations!
  18. LIBDIR="/usr/share/gnat/lib"
  19. src_install() {
  20. dodir ${MODULEDIR}
  21. insinto ${MODULEDIR}
  22. newins "${FILESDIR}"/gnat.eselect-${PV} gnat.eselect
  23. dodir ${LIBDIR}
  24. insinto ${LIBDIR}
  25. # !ATTN!
  26. # Make sure to adjust version of installed file to a proper one if there is
  27. # a change!
  28. newins "${FILESDIR}"/gnat-common-1.4-r1.bash gnat-common.bash
  29. }