honggfuzz-0.7.ebuild 612 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="A general purpose fuzzer with feedback support"
  6. HOMEPAGE="http://google.github.io/honggfuzz/"
  7. SRC_URI="https://github.com/google/honggfuzz/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND="
  13. sys-libs/binutils-libs:=
  14. sys-libs/libunwind
  15. "
  16. DEPEND="${RDEPEND}"
  17. DOCS=(
  18. CHANGELOG
  19. COPYING
  20. CONTRIBUTING
  21. README.md
  22. )
  23. src_compile() {
  24. emake CC="$(tc-getCC)"
  25. }
  26. src_install() {
  27. dobin ${PN}
  28. einstalldocs
  29. }