libhangul-0.0.12.ebuild 730 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
  5. HOMEPAGE="http://kldp.net/projects/hangul/"
  6. SRC_URI="http://kldp.net/frs/download.php/5855/${P}.tar.gz"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc ~ppc64 x86"
  10. IUSE="nls static-libs test"
  11. RDEPEND="nls? ( virtual/libintl )"
  12. DEPEND="nls? ( sys-devel/gettext )
  13. virtual/pkgconfig
  14. test? ( dev-libs/check )"
  15. src_configure() {
  16. econf \
  17. $(use_enable nls) \
  18. $(use_enable static-libs static) || die
  19. }
  20. src_install() {
  21. emake DESTDIR="${D}" install || die "emake install failed"
  22. dodoc AUTHORS ChangeLog NEWS README || die
  23. }