sunpinyin-2.0.4_pre20130108.ebuild 1011 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils multilib python-any-r1 scons-utils toolchain-funcs
  6. DESCRIPTION="A Statistical Language Model based Chinese input method library"
  7. HOMEPAGE="https://github.com/sunpinyin/sunpinyin"
  8. SRC_URI="https://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
  9. LICENSE="LGPL-2.1 CDDL"
  10. SLOT="0/1"
  11. KEYWORDS="amd64 ~ppc ppc64 ~x86"
  12. IUSE=""
  13. RDEPEND="dev-db/sqlite:3"
  14. DEPEND="${RDEPEND}
  15. ${PYTHON_DEPS}
  16. dev-util/intltool
  17. sys-devel/gettext
  18. virtual/pkgconfig"
  19. PDEPEND="app-i18n/sunpinyin-data"
  20. src_prepare() {
  21. epatch "${FILESDIR}"/${PN}-2.0.4-pod2man.patch
  22. epatch_user
  23. }
  24. src_configure() {
  25. tc-export CXX
  26. myesconsargs=(
  27. --prefix="${EPREFIX}"/usr
  28. --libdir="${EPREFIX}"/usr/$(get_libdir)
  29. )
  30. }
  31. src_compile() {
  32. escons
  33. }
  34. src_install() {
  35. escons --install-sandbox="${D}" install
  36. rm -rf "${D}"/usr/share/doc/${PN} || die
  37. dodoc doc/{README,SLM-inst.mk,SLM-train.mk}
  38. }