tpacpi-bat-1.1-r1.ebuild 837 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils systemd
  5. if [ "${PV}" = "9999" ]; then
  6. inherit git-2
  7. EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git https://github.com/teleshoes/tpacpi-bat.git"
  8. KEYWORDS=""
  9. else
  10. SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  11. KEYWORDS="~amd64"
  12. fi
  13. DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
  14. HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. IUSE=""
  18. DEPEND=""
  19. RDEPEND="sys-power/acpi_call
  20. dev-lang/perl"
  21. src_install() {
  22. dodoc README battery_asl
  23. dobin tpacpi-bat
  24. newinitd "${FILESDIR}"/${PN}.initd.1 ${PN}
  25. newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
  26. systemd_newunit tpacpi.service ${PN}.service
  27. }