12345678910111213141516171819202122232425262728293031323334 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils systemd
- if [ "${PV}" = "9999" ]; then
- inherit git-2
- EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git https://github.com/teleshoes/tpacpi-bat.git"
- KEYWORDS=""
- else
- SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- fi
- DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
- HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
- LICENSE="GPL-3"
- SLOT="0"
- IUSE=""
- DEPEND=""
- RDEPEND="sys-power/acpi_call
- dev-lang/perl"
- src_install() {
- dodoc README battery_asl
- dobin tpacpi-bat
- newinitd "${FILESDIR}"/${PN}.initd.1 ${PN}
- newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
- systemd_newunit tpacpi.service ${PN}.service
- }
|