lc-blasq-9999.ebuild 817 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit leechcraft
  5. DESCRIPTION="Cloud image storage services client (like Flickr or Picasa)"
  6. SLOT="0"
  7. KEYWORDS=""
  8. IUSE="debug +deathnote +rappor +spegnersi +vangog"
  9. DEPEND="
  10. ~app-leechcraft/lc-core-${PV}
  11. dev-qt/qtwidgets:5
  12. dev-qt/qtnetwork:5
  13. dev-qt/qtdeclarative:5
  14. rappor? ( dev-qt/qtxml:5 )
  15. deathnote? (
  16. dev-qt/qtxml:5
  17. dev-qt/qtxmlpatterns:5
  18. )
  19. spegnersi? (
  20. dev-libs/kqoauth
  21. dev-qt/qtxml:5
  22. )
  23. vangog? ( dev-qt/qtxml:5 )"
  24. RDEPEND="${DEPEND}"
  25. src_configure(){
  26. local mycmakeargs=(
  27. -DENABLE_BLASQ_DEATHNOTE=$(usex deathnote)
  28. -DENABLE_BLASQ_RAPPOR=$(usex rappor)
  29. -DENABLE_BLASQ_SPEGNERSI=$(usex spegnersi)
  30. -DENABLE_BLASQ_VANGOG=$(usex vangog)
  31. )
  32. cmake-utils_src_configure
  33. }